July 26, 2013

How to use your favourite plugins in Pro Tools 11 AAX and Logic Pro X

There are still a few plug-in developers who are yet to release their latest updates to fully support the new Pro Tools 11 AAX and the Logic Pro X AU 64-bit requirements. But, have no fear! If one of your favourite plug-ins is still not quite ready, there is always a workaround! With the release of Nomad’s MAGMA 1.6 update – MAGMA can now be used inside of AVID’s Pro…

Read More >>