MacOS 10.13 – Should you upgrade?

Apple have recently launched their latest macOS ‘10.13 High Sierra’. Although many of you who are Apple users may be keen to update your macs to the latest software, we strongly recommend that you hold off in doing so. That is at least until you have checked that all of your software and hardware will still work! Due to the changes that come with each update, some software/hardware will not be compatible with the new macOS. Therefore we’ve put together a list of which of our products will and won’t work with the latest software update; so you can see whether 10.13 High Sierra is for you, or whether you need to hold off on upgrading for a couple of weeks.

Officially compatible with MacOS 10.13 High Sierra

Logic Pro X – Logic Pro X 10.3.1 or later is compatible, however, earlier versions of Logic Pro X are not compatible with macOS High Sierra.

Reason – Version 9.5.2 or higher is compatible with High Sierra, however, 9.5.1 or below is NOT compatible.

Fabfilter – Rob Papen have confirmed that their plug-ins are officially compatible with macOS High Sierra.

Rob Papen – Rob Papen have confirmed that their products are officially compatible with macOS High Sierra.

ToontrackToontrack have announced that they have found no compatibility issues when testing their products with macOS High Sierra

Vienna Symphonic Library – VSL have uploaded new versions of their software which is fully compatible with macOS High Sierra to MyVSL Software Downloads on their site.

Not officially compatible with MacOS 10.13 High Sierra

Ableton – Will ensure full compatibility with Live 9.7.5, due for release in mid-October 2017, however current version is not currently compatible with macOS High Sierra.

Pro Tools – Not currently compatible with macOS High Sierra

Cubase – Not currently compatible with macOS High Sierra.

Garritan – Garritan have recommended not to upgrade to macOS High Sierra due to intermittent faults in compatibility.

Gothic Instruments – No official announcement regarding compatibility with macOS 10.13 High Sierra, recommended not to update.

iZotope – No official announcement regarding compatibility with macOS 10.13 High Sierra, recommended not to update.

Native Instruments – NI software and hardware products are not supported under macOS 10.13 High Sierra.

New Sonic Arts – No official announcement regarding compatibility with macOS 10.13 High Sierra, recommended not to update.

Output – No official announcement regarding compatibility with macOS 10.13 High Sierra, recommended not to update.

Overloud – No official announcement regarding compatibility with macOS 10.13 High Sierra, recommended not to update.

ProjectSAM – Not yet officially compatible with MacOS 10.13 High Sierra.

Softube – Currently under testing, check their system requirements page for updates.

Spectrasonics – Not yet officially compatible with MacOS 10.13 High Sierra.

Synthogy – No official announcement regarding compatibility with macOS 10.13 High Sierra, recommended not to update.

Zynaptiq – No official announcement regarding compatibility with macOS 10.13 High Sierra, recommended not to update.

We will keep updating this page, so make sure you keep checking back to see if your software/hardware has been made compatible with macOS 10.13 High Sierra.

Posted by Melanie Doidge

Having worked in marketing for over fifteen years with experience in various industries, Time+Space and the world of music production continues to be the most exciting of them all. With our brands consistently pushing the boundaries of technology with their products, the terrific DJs, Composers and Producers using them and the feedback from magazines and our customers, there's always plenty to tell the world about. Musical experience? I reached Grade 6 in piano back in my school days and am currently in the throes of trying to resurrect my abilities!

Website: http://www.timespace.com

Leave a Reply

Your email address will not be published. Required fields are marked *